Connection is not private - err_cert_common_name_invalid

I am building a firebase hosted Angular(Front End)/Node.js(Backend) and use Oxford api to lookup for a word and Audio does not play.
After further debugging when I try to access the link "" and directly tried in browser (both Chrome and Safari) I get the message "Connection is private"

I also tried to use https instead of http.

Issue got resolved if I say continue in my browser but I can't make the user to do before they start using.

I tried to search and could not find a single thread related to this so makes me think that I am missing something.

On the other hand, I see the the files are hosted on amazon s3 and something needs to be done by oxford to correct this but I am totally lost here..

Please help. If this cannot be resolved, I will have to make all the audio files myself and host it on my server and I'm really not looking forward to it.


  • SimoneSimone Administrator admin

    Hi @kriskish ,
    Apologies for the late reply to your question!

    We consulted with our technical team, and what you flagged up was an issue they were actually already looking into (but many thanks for flagging it up!).

    It has now been resolved.
    The API already supports both links with http and https - but for the moment, when you enter ‘audio’ on it, the link it will show you is this

    We are preparing an update to be released in early May, and once it goes live, the link that the API will show you when you request audio will be

    So the link you should be using is and you should no longer experience any difficulties, but please let us know if there is anything that is still not quite right!

Sign In or Register to comment.